• 编辑评测:高夫净源控油平衡露 极速补水长效控油 2019-06-14
  • 标记生成出错,请与管理员联系! 2019-06-14
  • 伊春市纪委监委通报7起违反中央八项规定精神的典型问题 2019-06-12
  • 第十二届人民企业社会责任奖评选启动 2019-06-12
  • 中国武器亮相国外 铁甲雄狮大秀视觉盛宴 2019-06-02
  • 城管炫富是病,得治! 2019-06-02
  • 陕西省贫困村驻村工作队选派管理办法出台 2019-05-26
  • 花开时节探访洛阳 遍地古迹中品读古都独特魅力 2019-05-26
  • “体育+旅游”使景区成为休闲度假目的地 2019-05-25
  • 就凭这样一句,你的思想就非常够呛,无视楼梯 2019-05-25
  • 成自泸高速货车冲到对面车道侧翻 致1死9伤 2019-05-21
  • “黄金单身汉”英国哈里王子宣布订婚 2019-05-16
  • 光是一个梨子的滋味就改变了方向,说讲事实摆道理,就是要你按他的指挥棒转,属于忽悠网友的口实 2019-04-18
  • 日照市妇幼保健院:免费健康体检送进福利院 2019-04-18
  • 【专题】2018贵州省两会 2019-04-12
  • 自由的生活_软路由论坛

     找回密码
     注册

    QQ登录

    只需一步,快速开始

    搜索
    查看: 1189|回复: 7
    打印 上一主题 下一主题

    新十一选五走势图: [无线] wifi有自动换频率的功能吗

    [复制链接]
    跳转到指定楼层
    1#
    发表于 2018-11-11 14:28:49 | 只看该作者 回帖奖励 |倒序浏览 |阅读模式

    马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

    广西11选5历史 www.jqel.net 您需要 登录 才可以下载或查看,没有帐号?注册

    x
    自带的wifi功能

    我需要的功能是:
    用scan 扫描一下哪个频率占用的少,自动改写。
    2412 2442 2462三选一。
    5180 5200 5805 三选一。
    这个脚本有吗?
    routeros
    2#
    发表于 2018-11-11 17:11:57 | 只看该作者
    问题是扫描的时候会断网
    routeros
    3#
     楼主| 发表于 2018-11-11 19:40:49 | 只看该作者
    我截图的界面,点了 scan。。。  出来一个界面不自动刷新信号,
    同时,用电脑ping手机, ping一直是通的。
    。
    坐等cspm333 大侠。
    routeros
    4#
     楼主| 发表于 2018-11-11 20:01:26 | 只看该作者
    设备都是长期不断电的, 我可以定时到 半夜5点执行。
    routeros
    5#
    发表于 2018-11-12 23:48:49 | 只看该作者
    本帖最后由 cspm333 于 2018-11-13 10:51 编辑

    小弟wifi是用asus分享器所以無實務經驗可以幫,
    不過wifi相關script是有,您可以依您的需求做修改試試:

    來源:MikroTik RouterOS Wireless (WiFi)使用Script自動更新頻率
    ※$ccq < 20表示訊號低於20就會變更頻率,數值可以自行調整。
    ※ freqList是頻率列表,可以自行修改成想要使用那些頻率。

    1. /interface wireless;
    2. :global waitingchange;
    3. :global ccqerror;
    4. :local interface [get number=0 ssid];
    5. :local freqList;
    6. :if ([:find [get $interface channel-width] "above"] > 0)  do={
    7.     :set freqList {2412;2417;2422;2427;2432;2437;2442};
    8. } else {
    9.     :set freqList {2432;2437;2442;2447;2452;2457;2462};
    10. }
    11. monitor $interface once do={
    12.     :local freqListLen [:len $freqList];
    13.     :local pos [:find $freqList $frequency];
    14.     :local ccq [        DISCUZ_CODE_0        ]quot;overall-tx-ccq";
    15.     :local regclients [        DISCUZ_CODE_0        ]quot;registered-clients";
    16.     :if ($regclients > 0) do={
    17.         :set waitingchange 0;
    18.         :if ($ccq < 20) do={
    19.             :set ccqerror ($ccqerror + 1);
    20.             :if ($ccqerror >= 6) do={
    21.                 :set ccqerror 0;
    22.                 :log info "Frequency($frequency) CCQ: $ccq%. Too low, change frequency";
    23.                 :set pos ($pos + 1);
    24.                 :if ($pos > 0) do={  } else { :set pos 0; }
    25.                 :if ($pos = $freqListLen) do={ :set pos ($pos - $freqListLen); }
    26.                 set $interface frequency=[:pick $freqList $pos];
    27.             }
    28.         } else {
    29.             :set ccqerror 0;
    30.             :if ($pos >= 0) do={  } else { set $interface frequency=[:pick $freqList 0]; }
    31.         }
    32.     } else {
    33.         :set ccqerror 0;        
    34.         :if ($waitingchange < 3) do={
    35.             :set waitingchange ($waitingchange + 1);
    36.         } else {
    37.             :set waitingchange 0;
    38.             :if ([:pick $freqList ($freqListLen / 2 - 1)] != $frequency) do={ set $interface frequency=[:pick $freqList ($freqListLen / 2 - 1)]; }
    39.         }
    40.     }
    41. }
    复制代码

    routeros
    6#
     楼主| 发表于 2018-11-15 01:46:08 | 只看该作者


    。
    我打算这样写,
    先设置为 2412  然后改写成自动,
    请问 如何用命令把 channel.frequency=2412  删除?

    点评

    /cap-man interface set [find mac-address=6c:3b:6b:cf:47:93] !$"channel.frequency"  发表于 2018-11-15 15:38
    routeros
    7#
     楼主| 发表于 2018-11-15 22:29:57 | 只看该作者
    本帖最后由 xuxi3201 于 2018-11-15 22:31 编辑

    /caps-man interface set [find name=RB952-5G] channel.frequency="2412"
    以上是指定,
    以下是改成不指定
    /caps-man interface set [find name=RB952-5G] channel.frequency=""

    6.42.9 测试通过。
    routeros
    您需要登录后才可以回帖 登录 | 注册

    本版积分规则

    QQ|小黑屋|手机版|Archiver|广西11选5历史 ( 渝ICP备15001194号-1,渝公网安备 50011602500124号 )

    GMT+8, 2019-6-18 05:11 , Processed in 0.170060 second(s), 25 queries , Gzip On, MemCache On.

    Powered by Discuz! X3.4 Licensed

    © 2001-2017 Comsenz Inc.

    快速回复 广西11选5历史 返回列表
  • 编辑评测:高夫净源控油平衡露 极速补水长效控油 2019-06-14
  • 标记生成出错,请与管理员联系! 2019-06-14
  • 伊春市纪委监委通报7起违反中央八项规定精神的典型问题 2019-06-12
  • 第十二届人民企业社会责任奖评选启动 2019-06-12
  • 中国武器亮相国外 铁甲雄狮大秀视觉盛宴 2019-06-02
  • 城管炫富是病,得治! 2019-06-02
  • 陕西省贫困村驻村工作队选派管理办法出台 2019-05-26
  • 花开时节探访洛阳 遍地古迹中品读古都独特魅力 2019-05-26
  • “体育+旅游”使景区成为休闲度假目的地 2019-05-25
  • 就凭这样一句,你的思想就非常够呛,无视楼梯 2019-05-25
  • 成自泸高速货车冲到对面车道侧翻 致1死9伤 2019-05-21
  • “黄金单身汉”英国哈里王子宣布订婚 2019-05-16
  • 光是一个梨子的滋味就改变了方向,说讲事实摆道理,就是要你按他的指挥棒转,属于忽悠网友的口实 2019-04-18
  • 日照市妇幼保健院:免费健康体检送进福利院 2019-04-18
  • 【专题】2018贵州省两会 2019-04-12
  • 2019深圳风采走势图 福彩3d一九图库 任选9场二等奖 荒野行动辅助网 游戏猎鱼达人直播 尼克斯vs篮网比分 大乐透规则 贵州11选5仼7推荐 幸运河北20选5开奖结果走势图 校内网篮球巨星 分分彩走势图怎么分析 寻仙手游2019平民职业 穿越火线小说 奔驰线上娱乐平台 两码中特免费公开资料 辽宁35选7每周开奖日期